Get in touch
Back
Resolved

New WhatsApp Outage -[Resolved]: WhatsApp Business Account Management

Started 13 Jun at 12:18am UTC.

Created

The fix for some disruptions impacting being able to view phone numbers on WhatsApp Business Manager has been deployed and this issue is now mitigated. Thank you for your patience.

Posted 13 Jun at 12:18am UTC.