Back
Resolved

New WhatsApp Outage -[Some disruptions]: WhatsApp Business Account Management
Started 12 Jun at 04:43pm UTC.
Created
Our engineering teams are still investigating and working on a fix for some disruptions impacting being able to view phone numbers on WhatsApp Business Manager. We will provide another update if additional information is available.
Posted 12 Jun at 04:43pm UTC.