Get in touch
Back
Resolved

New WhatsApp Outage -[Some disruptions]: WhatsApp Business Account Management

Started 9 Jun at 09:59am UTC.

Created

Our engineering teams are still investigating and working on a fix for some disruptions impacting being able to view phone numbers on WhatsApp Business Manager. We will provide another update within 24 hours or sooner if additional information is available.

Posted 9 Jun at 09:59am UTC.