Get in touch
Back
Resolved

Storage Outage

Started 23 Apr at 12:01am UTC.

Created

Event Type: Service Degraded Performance and Availability

Our Cloud Storage team is investigating a partial outage situation with our Object Storage infrastructure.

We are working quickly to restore service to its optimal state.

Posted 23 Apr at 12:01am UTC.